This is to update you that the situation has been resolved. The service is now restored and back to normal operation.
Apologies for any inconvenience caused and thank you for your patience and understanding. --- IDCloud Services team
Posted Oct 15, 2025 - 20:15 UTC
Monitoring
We've taken some corrective steps in the hopes of rectifying the issue. We are currently validating to ensure the fixes worked.
Apologies for any inconvenience caused and thank you for your patience and understanding. --- IDCloud Services team
Posted Oct 15, 2025 - 20:09 UTC
Investigating
Our monitoring system has detected turbulence on the IDCloud service.
At this time we don't have any reason to believe any service is down, however, we are seeing indications that there may be some intermittent failures possible.
We are investigating this issue and will provide updates as they become available.
Apologies for any inconvenience caused and thank you for your patience and understanding. --- IDCloud Services team
Posted Oct 15, 2025 - 19:19 UTC
This incident affected: OATH Strong Customer Authentication (Auth-Sign Service API).